VB.net 2010 视频教程 VB.net 2010 视频教程 python基础视频教程
SQL Server 2008 视频教程 c#入门经典教程 Visual Basic从门到精通视频教程
当前位置:
首页 > 网站开发 > JavaScript教程 >
  • 按需引入element-ui报错

按需引入element-ui报错

项目用的脚手架是 vue-cli 3
按照官方文档按需引入组件: https://element.eleme.cn/#/zh-CN/component/quickstart

安装 babel-plugin-component

npm install babel-plugin-component -D

vue-cli3搭建的项目中没有 .babelrc 文件,我是直接写在 babel.config.js文件中:

module.exports = {
  "presets": [["es2015", { "modules": false }]],
  "plugins": [
    [
      "component",
      {
        "libraryName": "element-ui",
        "styleLibraryName": "theme-chalk"
      }
    ]
  ]
}

运行项目,发现报错,报错信息如下:

在网上查阅资料对问题的解读是这样的:

项目是基于vue-cli 3.x的版本,并没有官网的.babelrc文件,只有babel.config.js文件,而且项目不需要引入完整的element-ui,只需要引入部分,按官网的步骤安装babel-plugin-component后在babel.config.js写入内容,报错

解决方案:

1.安装@babel/preset-env

npm i @babel/preset-env -D

2.修改.babelrc文件,把es2015改成@babel/preset-env

module.exports = {
  "presets": [["@babel/preset-env", { "modules": false }]],
  "plugins": [
    [
      "component",
      {
        "libraryName": "element-ui",
        "styleLibraryName": "theme-chalk"
      }
    ]
  ]
}

然后重新执行 npm run serve,就可以了

参考链接:https://blog.csdn.net/zy21131437/article/details/108029284

来源:
https://www.cnblogs.com/wj-forever/p/14899606.html


相关教程